SatanKid don't look at the exact numbers but at the difference between tests. You'll see that one test case consistently outperforms the other. The difference in speed per run is due to processing power being available and such.
Generally speaking, camel case can refer to both upper CamelCase and lower camelCase. However, in the JavaScript ecosystem the convention is to use camelCase as the naming for the lowercase version and PascalCase for the uppercase version. Therefor, this Kata should be renamed.
Would definitely use spaces, new lines and full variable names. This is not easy to read so not sure why this has been upvoted as a best practice. Clever at most.
This comment is hidden because it contains spoiler information about the solution
This comment is hidden because it contains spoiler information about the solution
SatanKid don't look at the exact numbers but at the difference between tests. You'll see that one test case consistently outperforms the other. The difference in speed per run is due to processing power being available and such.
Generally speaking, camel case can refer to both upper CamelCase and lower camelCase. However, in the JavaScript ecosystem the convention is to use camelCase as the naming for the lowercase version and PascalCase for the uppercase version. Therefor, this Kata should be renamed.
For reference, you could take a look at how it's explained in the airbnb guide which is pretty much the most popular JS style guide: https://github.com/airbnb/javascript#naming--PascalCase.
Would definitely use spaces, new lines and full variable names. This is not easy to read so not sure why this has been upvoted as a best practice. Clever at most.
This comment is hidden because it contains spoiler information about the solution
Quite readable? The lack of any new lines and multiple returns on one lie is poor form. I wouldn't approve code like this in merge requests.