Loading collection data...
Collections are a way for you to organize kata so that you can create your own training routines. Every collection you create is public and automatically sharable with other warriors. After you have added a few kata to a collection you and others can train on the kata contained within the collection.
Get started now by creating a new collection.
huh? Is there an explanation or is this trolling?
Okay so as I understand it this is an example of the "dynamic programming approach" to this classic challenge with a slight twist I still don't quite get. The classic approach might start with both current and total maximums equal to the first element. In each iteration it would compare the current element to currentMax + a instead of comparing it with zero. Aside from that, it's the same and you can Google it. So, why are you using zeros instead of elements? Does this always work?
Sure, but could someone explain it?
Thanks for showing me a new syntax! Much cleaner than building the dictionary inside the where clause, and probably about the same performance.
I'll never understand the tempatation to fit your code into as small a space as possible at all costs. Why in the world would you omit white space between symbols and sacrifice performance just to have the most terse answer?
This comment is hidden because it contains spoiler information about the solution
It's a very, very bad practice to put comments describing code that describes itself. The code is clean and self-explanatory. Why dirty it?
Loving this syntax.
This is very difficult to follow and extremely complex. Any reason in particular why someone would tick best practices? Is this revolutionary in its efficiency on large datasets or something?
Ugly as heck. Why on earth would you omit white space? Why would you want your solution to be extra cryptic and extra difficult to read? Not even going to critique beyond "this is hard to look at"...
Yeah what's the point of Distinct()?
I'm curious why calling Distinct()?
It bafles me why people would favor cryptic implementations. TBH I hate this solution. Why no spaces? Why not give your variable a meaningful name? WHY NO SPACES?
A bit too cryptic with poor readability, or maybe the syntax is just new to me? It's confusing how the return value is incremented with each recursion.
A bit too cryptic with poor readability, or maybe the syntax is just new to me? It's confusing how the return value is incremented with each recursion.
Loading more items...