Well in that case I wouldn't name the variable as "n". It doesn't mean anything and decreases the readability.
"f" would be cool, or better: "friend".
"Input strings will only contain letters."
How about the name with number ?
Great solution, thank you. I overcomplicated myself using .split("") and a condition but this is smart. Gotta remember about filter.
Names with numbers will be a trend .. apparently
Description says "a name has exactly 4 letters in it". Not numbers.
This comment is hidden because it contains spoiler information about the solution
i have a doubt, how do you prove that a b c are greater than 0? i used a boolean to prove that a b c are > 0
I only dislike "n" as a name. "N" doesn't say anything about what we are dealing with. It should be friendName or friend imo.
The same as mine
This soulution passed only basic test? bcs string from 4 numbers like '3333' is not a name)
Because the author doesn't mention it and everyone is lazy pretty much
In any case, the code above can give a name consisting of 4 digits.
Numbers in the basic tests: assert.deepEqual(friend(["Ryan", "Jimmy", "123", "4", "Cool Man"]), ["Ryan"])
The tests only pass strings containing letters. Otherwise, it is expectable the description would state it, and provide some more examples to see the different cases.
Loading collection data...
Well in that case I wouldn't name the variable as "n". It doesn't mean anything and decreases the readability.
"f" would be cool, or better: "friend".
"Input strings will only contain letters."
How about the name with number ?
Great solution, thank you. I overcomplicated myself using .split("") and a condition but this is smart. Gotta remember about filter.
Names with numbers will be a trend .. apparently
Description says "a name has exactly 4 letters in it". Not numbers.
This comment is hidden because it contains spoiler information about the solution
This comment is hidden because it contains spoiler information about the solution
i have a doubt, how do you prove that a b c are greater than 0? i used a boolean to prove that a b c are > 0
I only dislike "n" as a name. "N" doesn't say anything about what we are dealing with. It should be friendName or friend imo.
The same as mine
This soulution passed only basic test? bcs string from 4 numbers like '3333' is not a name)
Because the author doesn't mention it and everyone is lazy pretty much
In any case, the code above can give a name consisting of 4 digits.
Numbers in the basic tests:
assert.deepEqual(friend(["Ryan", "Jimmy", "123", "4", "Cool Man"]), ["Ryan"])
The tests only pass strings containing letters. Otherwise, it is expectable the description would state it, and provide some more examples to see the different cases.
Loading more items...