Loading collection data...
Collections are a way for you to organize kata so that you can create your own training routines. Every collection you create is public and automatically sharable with other warriors. After you have added a few kata to a collection you and others can train on the kata contained within the collection.
Get started now by creating a new collection.
This comment is hidden because it contains spoiler information about the solution
You should change name of method from fixSize() to something meaningful, size should be fixed it means decrease or increase? Better to name this method as increaseSize()
So basically, in few words:
you want fixSize() to return a copy of the original array into a bigger array.
Instead of making these static methods called on some array you pass in, how about making the class work like ArrayList, ie you create an object of that type and apply methods(like add/remove, size, get) that treat it as a List with unlimited( on a machine with inifinte memory and computation time ) size, but size() still returns the correct number of elements in that list.
Basically, a kata to make an implementation of ArrayList, hell, even add generics.
That's what I actually thought this kata was when I read the description.
Can anyone explain to me what does fixSize() mean ?
Too vague. Solved by guesswork.
The instructions are too vague.
The big problem is that I don't understand the meaning of this problem!
Description of task is so crazy. I've not understood it.
True sorry about that. Just wanted to mark it with major issues. I'll close this one.
I think creating an issue to solve several issues that have just been raised no more than 10 minutes ago is a bit excessive
This kata still needs a lot of work. See @bkaes comments for details.
ExtendArray.getLength
doesn't get tested at all. However, neitherExtendArray.getLength
norExtendArray.get
actually contribute anything to the kata.You're creating instances just to test static methods:
That's quite strange. Instead, use the class method:
You don't actually tell what
ExtendArray.fixSize
should do. The name suggests that it should fix a broken size, but your code suggests that it should enlarge the array.Loading more items...