Ad
  • Default User Avatar

    Solution is good, I would suggest using more descriptive names (obviously codewars isn't exactly nudging us in the right direction with parameter names like "s").

    For example: "s1" and "s2" tell us nothing about the variables - something like "capitalizedAtEven" and "capitalizedAtOdd" would be clearer (although still not perfect).

  • Custom User Avatar

    Nice solution. One small tip, you can use [string, string] as the return type for capitalize if you want to be more specific. This will only accept an output array of two strings.

    Cheers!