Loading collection data...
Collections are a way for you to organize kata so that you can create your own training routines. Every collection you create is public and automatically sharable with other warriors. After you have added a few kata to a collection you and others can train on the kata contained within the collection.
Get started now by creating a new collection.
Yes, it's by default. It's not marked as a big warning, but as a suggestion. To me, I repeat, it's such a small difference that I think it's a matter of taste :) If i had to back up this in a more objective way, I would resort to the DRY principle. Writing
string a = ''
is like saying to time that it is a string, hence providing redundant information. I don't think thatvar a = ''
has any readability problem :).As I said, I don't think it's weird, just stylistic decisions :)
I can commit only a certain amount of time to codewars, I try to do the best I can in a reasonable amount of time :)
Thanks for commenting :)
I guess that
var
has a lot to do with opinions and personal feeling of the coder, is difficult to say what is better to use objectively, whether var or the actual type. Personally, I usevar
everywhere, probably because I am addicted to resharper, it's concise, and because I like to use type inference whenever I can, but as I said, I think it's more a matter of taste.If I had to put this code in a real project, I guess I would have added a documentation for
Seq
, and maybe chose a better name :)try with
.Trim()
? maybe the whitespace is on the other sideYou should look into
StringBuilder
if you don't want to dry up your memory ;)that's true, also
ToList
=)Isn't the OfType redundant?