Ad
  • Custom User Avatar

    The ternary operator really isn't needed here, as it would return true and false for those cases anyway. So this solution could be simplified by removing it.

  • Custom User Avatar

    You don't need the last if-clause. Just return first && second && third directly.

    There's also a tiny typo there, "thrid" instead of "third" ;)

  • Custom User Avatar

    Good job introducing local variables with reasonable names, that way you can immediately see what's going on.

    However, I think some of these comments could be removed. For example "End Loop Here", because, for me, it adds more noise than clarity.

    Nontheless, well done!

  • Custom User Avatar

    I like that you renamed the method parameters, I did a similar thing.
    Short variable names are really bad, since you can't immediately see what they stand for.

    Good job!