True, wasn't really thinking of using a method like this in a huge program or O(n) at all. If the array was never very long than reallocating wouldn't be all that bad.
Also, no need for 'else' statement after 'return' statement
You just turned a O(n) solution into a O(nlgn) solution :p
int max=Integer.MIN_VALUE,min=Integer.MAX_VALUE;
I believe it's better to assign them both to nums[0]. I'm not sure if it uses less memory but it's more readable and logical.
Loading collection data...
True, wasn't really thinking of using a method like this in a huge program or O(n) at all.
If the array was never very long than reallocating wouldn't be all that bad.
Also, no need for 'else' statement after 'return' statement
You just turned a O(n) solution into a O(nlgn) solution :p
int max=Integer.MIN_VALUE,min=Integer.MAX_VALUE;
I believe it's better to assign them both to nums[0].
I'm not sure if it uses less memory but it's more readable and logical.