Loading collection data...
Collections are a way for you to organize kata so that you can create your own training routines. Every collection you create is public and automatically sharable with other warriors. After you have added a few kata to a collection you and others can train on the kata contained within the collection.
Get started now by creating a new collection.
This comment is hidden because it contains spoiler information about the solution
I'm curious on all these .repalce() answers does the .trim() have to loop over the string a second time? I wonder if there is a way to get it in one pass?
Would this break when minified because there is no semicolon? Is semicolon best practices?
I had thought about doing this because my first solution was timing out. It is cool that it works. Great job.
This is what I did too, I was very skeptical of myself as I continued to nest the returns but very satisfied when it worked.
Well, while sample tests are indeed not obligatory, lack of them is often considered a kata problem, isn't it?
Not an issue. 11,000+ people completed in javascript. Press attempt.
In JS, I'm getting the wrong tests. The tests should be expecting an array of anagram matches or an empty array but they look like this ...
// Since Node 10, we're using Mocha.
// You can use
chai
for assertions.const chai = require("chai");
const assert = chai.assert;
// Uncomment the following line to disable truncating failure messages for deep equals, do:
// chai.config.truncateThreshold = 0;
// Since Node 12, we no longer include assertions from our deprecated custom test framework by default.
// Uncomment the following to use the old assertions:
// const Test = require("@codewars/test-compat");
describe("Solution", function() {
it("should test for something", function() {
// Test.assertEquals(1 + 1, 2);
// assert.strictEqual(1 + 1, 2);
});
});
And no matter what I do the tests won't pass, I can't get console logs to display anything in the left panel either.
Sorry for the late reply. So the empty string before I put the line number tells java that this is String addition. In this case, I am not sure it is necessary beacause I am adding another String right after. Also, I made this a long time ago, so this is not good coding practice at all. String addition is generally bad practice because it takes up extra memory (Strings are immutable).
Just to answer your question more clearly:
(5) is an int
("" + 5) is a String
For clarity, String.valueOf(5) is probably better.
Hi I'm new. Why have the empty string before the line number?